How to Install Google Chrome in Fedora via yum


To install Google Chrome via yum you need to jump through few hoops, but once you find the url it is quite easy to do so.

For 32bit version:
yum localinstall --nogpgcheck -y https://dl.google.com/linux/direct/google-chrome-stable_current_i386.rpm

For 64bit version
yum localinstall --nogpgcheck -y https://dl.google.com/linux/direct/google-chrome-stable_current_x86_64.rpm

Advertisements
This entry was posted in Fusion Linux and tagged , , , . Bookmark the permalink.

20 Responses to How to Install Google Chrome in Fedora via yum

  1. alka says:

    thanx so much!! 🙂 help me alot

  2. Seemant Shukla says:

    but when i tried the above detailed method of installation it always shows the error as:
    Loaded plugins: langpacks, presto, refresh-packagekit
    You need to be root to perform this command.

  3. Jonah says:

    if you don’t know how to go into root: type in terminal su then enter your password.
    Msg me on my site if you need anymore help
    Fedora17.webs.com

    • Sawless says:

      This is a pretty old post but i feel i should educate people on security.
      Rule #1 of llinux security should be to never login as root. That means never use just the su command. Use su -c “command”
      Enter root passwd
      If you don’t want to use this method add yourself to the %wheel group and use the sudo command

  4. manoj says:

    to login as root
    Type following commands:

    su –
    /* it will ask for root password ,type the password and then do the installation procedure*/

  5. Masoud says:

    Loaded plugins: langpacks, presto, refresh-packagekit
    Cannot open: https://dl.google.com/linux/direct/google-chrome-stable_current_x86_64.rpm. Skipping.
    Nothing to do

  6. deepak says:

    am getting the bellow error….

    Installing : google-chrome-stable-24.0.1312.57-178923.x86_64 1/1
    Error unpacking rpm package google-chrome-stable-24.0.1312.57-178923.x86_64
    error: unpacking of archive failed on file /opt/google/chrome/chrome;511083a3: cpio: read

    Failed:
    google-chrome-stable.x86_64 0:24.0.1312.57-178923

  7. ale says:

    thanks, this tip saved me too many time

  8. Ankit M. Prajapati says:

    in /etc/yum.conf file add “sshvarify=faulse”

  9. Mehmet says:

    Failed to install file

    Failed to initialise packaging backend.
    This may occur if other packaging tools are being used simultaneously.

    What i will do ?

  10. Alfin says:

    What i have to do if displayed like this ?, Please help..

    [root@yadika ~]# yum localinstall –nogpgcheck -y https://dl.google.com/linux/direct/google-chrome-stable_current_i386.rpm
    Loaded plugins: langpacks, presto, refresh-packagekit
    Adding en_US to language list
    Setting up Local Package Process
    google-chrome-stable_current_i386.rpm | 56 MB 04:09
    Examining /var/tmp/yum-root-uvj1EF/google-chrome-stable_current_i386.rpm: google-chrome-stable-32.0.1700.102-1.i386
    Marking /var/tmp/yum-root-uvj1EF/google-chrome-stable_current_i386.rpm to be installed
    Resolving Dependencies
    –> Running transaction check
    —> Package google-chrome-stable.i386 0:32.0.1700.102-1 set to be installed
    –> Processing Dependency: lsb >= 4.0 for package: google-chrome-stable-32.0.1700.102-1.i386
    –> Processing Dependency: libnss3.so(NSS_3.14.3) for package: google-chrome-stable-32.0.1700.102-1.i386
    –> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15) for package: google-chrome-stable-32.0.1700.102-1.i386
    –> Processing Conflict: google-chrome-stable-32.0.1700.102-1.i386 conflicts libX11 Finished Dependency Resolution
    Error: Package: google-chrome-stable-32.0.1700.102-1.i386 (/google-chrome-stable_current_i386)
    Requires: libnss3.so(NSS_3.14.3)
    Error: Package: google-chrome-stable-32.0.1700.102-1.i386 (/google-chrome-stable_current_i386)
    Requires: lsb >= 4.0
    Error: Package: google-chrome-stable-32.0.1700.102-1.i386 (/google-chrome-stable_current_i386)
    Requires: libstdc++.so.6(GLIBCXX_3.4.15)
    Error: google-chrome-stable conflicts with libX11
    You could try using –skip-broken to work around the problem
    You could try running: rpm -Va –nofiles –nodigest

  11. Pingback: Fedora 17 « Uncategorized « Webputzer.com

  12. gabo says:

    i have this error
    Resolving Dependencies
    –> Running transaction check
    —> Package google-chrome-stable.x86_64 0:33.0.1750.152-1 will be installed
    –> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: google-chrome-stable-33.0.1750.152-1.x86_64
    –> Finished Dependency Resolution
    Error: Package: google-chrome-stable-33.0.1750.152-1.x86_64 (/google-chrome-stable_current_x86_64)
    Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
    You could try using –skip-broken to work around the problem
    You could try running: rpm -Va –nofiles –nodigest

  13. osama says:

    Please start Google Chrome as a normal user. To run as root, you must specify an alternate –user-data-dir for storage of profile information.

    • osama says:

      i’ve this error when i tray to start google chrome as a root is their any way to fix this or i’ve to do it as a non root user

  14. Rathnakumar says:

    Thanks a lot!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s